ひよっこ。

I want to…

agiloをインストールしたら有効化されなくてはまった

Posted by hikaruworld : 2009 12月 9

結論はGenshiのバージョンが古かったこと。

自分の場合、easy_install を利用して全環境に適用可能にするのではなく、
任意の環境のpluginsフォルダにインストールするケースが多い。
理由はいくつかあるが、もっとも大きいのは属性やスコープの違うtracを複数運用しているため。
# 開発用だったり、あるいは運用用だったり、要件管理用だったり。

そんなわけでagilo

python setup.py bdist_egg

でインストール→コピー→プラグイン有効化したわけだが、なぜか画面に表示されない。

agiloのsetup.pyを確認してみたが、必須モジュールのGenshiもsimplejsonもインストールしている。

   install_requires=['trac >= 0.11',
                      'genshi >= 0.5.1, < 0.6dev', # see Genshi bug #254
                      'simplejson'
                      ], 

変だなーと思いつつログを確認してみると、以下のようなエラーが出てる。

2009-12-09 14:38:36,916 Trac[loader] ERROR: Skipping “agilo 0.8.3-r1918-20090925”: (version conflict “(Genshi 0.5 (/usr/local/Python252/lib/python2.5/site-packages/Genshi-0.5-py2.5-linux-i686.egg), Requirement. parse(‘genshi>=0.5.1,<0.6dev'))")

なるほど、つまりGenshiのバージョンが古いと。

easy_installを使ってGenshiのバージョンをUpdateした

easy_install -U Genshi

するとGenshiのバージョン0.5.1がインストールされたのでapache再起動

…今度はInternalServerError….orz.

ExtractionError: Can’t extract file(s) to egg cache\n\nThe following error occurred while trying to extract file(s) to the Python egg\ncache:\n\n [Err no 13]

なんか、懐かしいバグにあったったみたい。
easy_install.pthからGenshiの行を削除してeggファイルを削除して再度Genshiをインストール。

easy_install --always-unzip Genshi

DBをupdate。
OK-。

無事確認できた。
なんかいらん事にはまってしまったorz…

コメントを残す

以下に詳細を記入するか、アイコンをクリックしてログインしてください。

WordPress.com ロゴ

WordPress.com アカウントを使ってコメントしています。 ログアウト / 変更 )

Twitter 画像

Twitter アカウントを使ってコメントしています。 ログアウト / 変更 )

Facebook の写真

Facebook アカウントを使ってコメントしています。 ログアウト / 変更 )

Google+ フォト

Google+ アカウントを使ってコメントしています。 ログアウト / 変更 )

%s と連携中

 
%d人のブロガーが「いいね」をつけました。