ひよっこ。

I want to…

    広告
  • つぶやき。。。

    • 間違って違うワークスペースでヘルプを出してしまった。怖... 19 hours ago
    • うーん、notificationなどで利用するComponent内で限定した(Reactで言う)stateを持ちたいんだけど...。素直にhyperappのstateで保持するか。 1 day ago
    • ふと気になって調べてみたら、ESNextの OptionalChainingはstage1にはいるのか。 github.com/tc39/proposal-… 2 days ago
    • @JorgeBucaran ありがとうございます。ちょっと試してみます。ondestroyのログは取れてたので、 > This event is not called in its child elements. が原因かなと思ってました。 2 days ago
    • SlackってNGOや教育割り引きあったのか。おおよそ85%オフとのこと get.slack.help/hc/ja/articles… 2 days ago
  • archive

  • ジャンル

  • tag

homebrewでError: node has multiple installed versionsって怒られた。

Posted by hikaruworld : 2011 6月 6

homebrewでいらんモジュールをアンインストールしようとしたら、
こんな感じで怒られました。

bash-3.2$ brew uninstall node

Error: node has multiple installed versions
Use `brew remove –force node` to remove all versions.

–forceを使えと言われたんですが、ちょっと気になって、infoでのぞいてみます。

bash-3.2$ brew info node

node 0.4.8
http://nodejs.org/
/usr/local/Cellar/node/0.4.7 (72 files, 7.5M)
/usr/local/Cellar/node/0.4.8 (72 files, 7.6M) *

あ、古いのも残ってるんですね。
というわけで,clean

bash-3.2$ brew clean

改めて削除。

bash-3.2$ sudo brew uninstall node

Uninstalling /usr/local/Cellar/node/0.4.8…

と、無事完了。

広告

コメントを残す

以下に詳細を記入するか、アイコンをクリックしてログインしてください。

WordPress.com ロゴ

WordPress.com アカウントを使ってコメントしています。 ログアウト / 変更 )

Twitter 画像

Twitter アカウントを使ってコメントしています。 ログアウト / 変更 )

Facebook の写真

Facebook アカウントを使ってコメントしています。 ログアウト / 変更 )

Google+ フォト

Google+ アカウントを使ってコメントしています。 ログアウト / 変更 )

%s と連携中

 
%d人のブロガーが「いいね」をつけました。